PhpDocumentor2 avec Php 7

De Movilab.org
Révision datée du 20 décembre 2016 à 10:07 par DavidRechatin (discussion | contributions) (Page créée avec « Testé sous Ubuntu 16.10... Installation des dépendances <blockquote> sudo apt install composer php7.0-mbstring </blockquote>Téléchargement du code source de phpDoc... »)
(diff) ← Version précédente | Voir la version actuelle (diff) | Version suivante → (diff)

Testé sous Ubuntu 16.10...

Installation des dépendances

sudo apt install composer php7.0-mbstring
Téléchargement du code source de phpDocumentor2
git clone https://github.com/phpDocumentor/phpDocumentor2.git
Modification pour compatibilité avec php 7
cd phpDocumentor2 git checkout master nano composer.json

modififier

... "require": { "php": ">=7.0.0", ...

Installation de phpDocumentor2
composer update composer install
Lancement
cd bin ./phpdoc -d /home/user/path/project -t /home/user/path/documentation